VPN Issues? Perhaps we have the same symptoms..


Recently I went digging for a solution to a problem which has been bugging me on Windows Server 2008. 

It seems once connected to a virtual private network (via PPTP, peer to peer tunnelling) when you try to authenticate to non-VPN network resources, Windows passes your VPN credentials instead – even to local system resources like Internet Information Services web server (running on your local machine), or a file share on a different machine in your local network.

This is obviously annoying since it’s very likely that your VPN credentials are only meant for use against the VPN network.  As I went trawling the Internet I cam across only one really helpful forum, located (1) here.

It might be worth trying out.  Basically, once you’ve created your VPN connection, open a command window and type:
cmdkey /delete /ras

It may work for you.. It may not.  It’s worth a shot, I think at this point in time.  Later, I’ll check Microsoft Connect to see if anyone has logged this as a potential defect in Windows Vista and Server 2008.

[ (1) http://bink.nu/forums/p/9533/17018.aspx ]
[ (2) http://connect.microsoft.com ]


About Rob Sanders

IT Professional and TOGAF 9 certified architect with nearly two decades of industry experience, 18 years in commercial software development and 11 years in IT consulting. Check out the "About Rob" page for more information.

Leave a comment

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>