Windows 8 doesn’t display image thumbnails 2


imageThis is a quick tip for those running Windows 8 who encounter this occasional problem where the Windows Explorer doesn’t display image thumbnails.

Now, I’m going to assume that you’ve already checked the Explorer settings, and so on.  This fixes a condition where the thumbnails appear very briefly (they flicker on then off) before displaying the default icon.  The standard settings don’t have any effect.

The trick is to delete the local icon cache.  The steps are relatively easy – first make sure you have killed all instances of explorer.exe before beginning.  Best way is to fire up Task Manager and end any explorer.exe process.  Then run a command line (as administrator if UAC is enabled). 

At the prompt type:

  • cd /d %userprofile%\AppData\Local
  • del IconCache.db /a
  • cd\
  • explorer

This will delete the local icon cache and reload an explorer instance.  It works for me.


About Rob Sanders

IT Professional and TOGAF 9 certified architect with nearly two decades of industry experience, 18 years in commercial software development and 11 years in IT consulting. Check out the "About Rob" page for more information.


Leave a comment

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

2 thoughts on “Windows 8 doesn’t display image thumbnails